Don’t run MySQL 5.5 on OSX

So while setting up a Rails2 development environment with RVM for one of my clients on my new Mac, I came across the infamous uninitialized constant MysqlCompat::MysqlRes error. Typically this is because the mysql gem isn’t compiled with the right archflags, but of course that wasn’t the case. After messing with it for a bit, I found out that the MySQL server I was running was 5.5.10, and 5.1 is supposedly more stable. So I downgraded it and everything worked.

credit: this post helped a bit.

, , ,

No comments yet.

Leave a Reply